Knowledgebase : Active Sky for P3Dv4 (ASP4)
   
Lockheed Martin, the developers of Prepar3D, provide updates quite frequently. 

We always work to provide an update for new version compatibility within a day or two after a new sim version is released, but it may take up to several days in some circumstances.  For this reason we recommend not updating your sim until your add-ons (Active Sky and any others) can be made/confirmed compatible.

We usually release an "OPEN BETA" version of our update initially, and these are posted at and available for download at http://hifisimtech.com/downloads.  BETA versions are to be used at your own risk and may include bugs or other issues.  We like to officially release an update within 30 days of starting OPEN BETA.

Brand new major versions of P3D, or brand new simulators entirely, are not expected to be supported, and generally require significant design changes and a major upgrade of the Active Sky version for compatibility and integration.
Keywords: CTD, startup, thunder

If ASP4 is crashing after thunder sound:

Symptoms:

Users with application startup sound enabled (default) will hear thunder sound and may see ASP4 splash screen for an instant before crashing. 

Cause:

Corruption of the wx download file and/or invalid weather download due to recent network maintenance.

Remedy:

Please try the following steps to correct this.  Close ASP4 and delete the file titled LastDownloaded.Wx located in; example: C:\Users\User Name\AppData\Roaming\Hifi\AS_P3Dv4\Weather and restart ASP4, a new LastDownloaded.Wx will be created; Or uninstall/reinstall ASP4 and remove saved data when prompted.

If you continue having problems after ensuring that the above items are completed please open a support ticket and include as much information as possible including your AS_P3Dv4_Log_Export.txt which can be created by pressing the "Logs" button on the ASP4 Home screen.

Keywords: Rain, starts, stops, precip, AS16, ASP4, ASN


Related Product(s): Active Sky 2016 for FSX and Prepar3D v3, Active Sky for Prepar3D v4, Active Sky Next


Description

We often receive technical support requests regarding the unexpected starting and stopping of rain/precip in FEW and SCT (scattered) cloud coverage conditions when rain is reported even though SH (showers) are not indicated.  This is working properly and as designed according to our advanced precipitation and radar simulation which accurately considers actual cloud depiction in sim and applies the realistic behavior/rule that precip cannot fall from clear air.  Clouds move with wind in FSX and P3D, and in FEW and SCT conditions, it is normal for rain to start and stop accordingly as occasional nimbus clouds pass overhead, regardless of SH (showers) element existing in the METAR string.


Details

The effect is described in the AS16 (pg 35) and ASP4 (pg 33) User's Guide - Generic Precipitation Display.

AS16 and ASP4 include advanced precipitation and radar features which constantly monitor the cloud positions as actually depicted within the simulator.  The occurrence, type and intensity of precipitation will thus change depending on the existence, type, thickness and convection properties of the simulated cloud that is overhead the aircraft.

Users will experience what may appear as "showery precip" as "few" or "scattered" nimbus (rain) clouds pass overhead, so it will be normal for rain to start and stop or change intensity over time.

Steady rain will occur when the area is covered in overcast cloud layers or fast moving broken layers (typical with nimbostratus).

METARs are a glimpse in time, showing conditions at the time of observation, using equipment such as ceilometers (measuring cloud base heights and coverage) and rainfall sensors (if equipped).  The measurement location and scope is very specific and small, and does not account for change over time even as short as a few seconds/minutes.  The use of the SH (showers) METAR element is generally associated with convective precipitation i.e. cumulonimbus and not indicated in the more stable non-convective nimbus clouds. 


If you require further assistance please visit the forum or feel free to submit a ticket.

Please also see this link for REQUIRED INFORMATION when submitting a ticket:

http://support.hifitechinc.com/Knowledgebase/Article/View/29/0/required-information-when-submitting-a-support-ticket


More Information

For more information please visit:

HiFi Forums: http://www.hifitechinc.com/forums

HiFi Support Center: http://support.hifitechinc.com/

 

Error: Crash/error on startup of any Active Sky product (FileNotFoundException referencing _nLoad)

Details:


We have had a few reports recently from false-positive via Microsoft Windows Defender where detection will initiate on temp files created by what appears to be standard .NET operations.  We have confirmed multiple times that no malware exists and have repeatedly sent files for analysis to Microsoft, where it will clear, but then come back occasionally for some users.  During updates of our products, we notice a higher frequency of these issues since it appears the previous "whitelisting" of our software is no longer valid for the new version and must undergo this new "whilelisting" process.  

We apologize for the inconvenience, however this is beyond our control and apparently due to aggressive "code detection" with false-positives.  There are several solutions to resolve this:

1) Please ensure your Windows is up to date with all the latest updates

2) Ensure that Windows Defender has been updated with latest virus definitions

3) Uninstall Active Sky, remove any "quarantined" items from Windows Defender

4) Reinstall Active Sky

These steps will usually allow Active Sky to run properly without further issues.


If the issue continues, the following steps will allow the product to run:

1) In Windows Defender, either allow the detected threat or exclude the found item.  See this link for details: https://www.thewindowsclub.com/manage-quarantined-exclusions-windows-defender-security-center

2) It is recommended to submit the detected threat to Microsoft to have them analyze and whitelist/clear this software accordingly to prevent this from happening in the future.  You can submit threats for analysis here: https://www.microsoft.com/en-us/wdsi/filesubmission

If you are unable to obtain resolution with the above steps, please open a new ticket with details and we will assist directly.

Since approximately the last week of October 2017, several users have reported a problem where ASP4 (Active Sky for Prepar3D v4) or AS16 (Active Sky 2016, For FSX or for P3D v3) fails to start.  The window does not open and nothing appears to happen.

We have numerous confirmations that some Anti Virus software has been blocking AS, and adding an exclusion (which allows the program to operate) will resolve the issue in such cases.  AVG specifically has been common in this regard.  Please see your AV software manual or search for "Excluding Applications in XXXX AV software" for instructions.  The exclusion settings are usually a main configuration item available from your AV software's main application screen.  For AVG, see this article for instructions: https://support.avg.com/SupportArticleView?l=en&urlName=How-to-exclude-file-folder-or-website-from-AVG-scanning&supportType=home

The items that should be excluded:

The application itself, i.e. [Active Sky Install folder]\AS_P3Dv4.exe or AS16.exe
The simulator i.e. [Simulator install folder]\Prepar3D.exe or FSX.exe
The ASConnect module folder i.e. [Simulator install folder]\as_srv

In some cases, your AV software may not allow exclusion of an entire folder.  In that case we recommend excluding the module .dll itself which is [Simulator install folder]\as_srv\as_connect_64.dll (for ASP4) or as_btstrp.dll (for AS16).

Note that these exclusions may have to be re-added after updating Active Sky in the future.

We recommend that you contact your AV software provider to let them know of this "false positive" regarding Active Sky.  We have already contacted the known false-positive providers, but they require that the licensed users contact them as well.

An alternative solution to this problem has also been confirmed by a few users:  Check the "Compatibility Mode" option in compatibility/advanced settings for the AS_P3Dv4.exe or AS16.exe application, and choose "Windows 8".  This may be helpful for those having trouble adding the exclusions in their AV software.

If you continue having problems after ensuring that the above items are excluded, and/or Compatibility mode enabled, please open a support ticket and include as much information as possible including your AV software type/version and a screenshot or details regarding your exclusions.

If P3Dv4 is crashing on first load:

Please try the following steps to correct this:

First, make sure you have installed the latest Active Sky for P3Dv4 build from www.hifisimtech.com/downloads .

Next, try running the [sim]\as_srv\as_btstrp_config_manager.exe program "as administrator" by right clicking it and choosing "Run as Admin".

Next, Try a full ASP4 uninstall/reinstall and choose to remove all saved data during uninstall.

If the problem remains, and you are comfortable using regedit at your own risk, you can manually remove the blocking entry for as_connect_64.dll by removing the entry in the AppCompatFlags Layers in the registry, as outlined in this thread: https://hifisimtech.com/forums/showthread.php?8454-P3D-V4-Open-Beta-P3D-crash-to-desktop-after-installing-AS-for-P3d-v4&p=40491&viewfull=1#post40491

Finally, you may want to try disabling other add-ons to identify if there is a problem with interaction.  If you need support please open a ticket with further details.



If P3Dv4 is crashing intermittently or after weather loads:


Please try the following steps to correct this:

First, make sure you have installed the latest Active Sky for P3Dv4 build from www.hifisimtech.com/downloads .


Next, Try a full ASP4 uninstall/reinstall and choose to remove all saved data during uninstall.

Next, if you use ASCA, try an ASCA uninstall/reinstall and make sure to install all SP2 updates and HD content (and HD Content updates) if you use 4096 mode.  Updates are here: www.hifisimtech.com/downloads

Finally, you may want to try disabling other add-ons to identify if there is a problem with interaction.  If you need support please open a ticket with further details.

Related Product: ASN, AS16, ASP4 All Versions



Description


Not enabling detailed clouds (and instead using simple non-3D clouds) will produce a block pattern on radar imagery including 3rd party NDs using Active Sky Radar integration.


This is a known configuration issue. The simulator is incorrectly set to simple (non-detailed) clouds which are essentially low-resolution rectangles and the radar/precipitation is correct given the low resolution of the precipitation boundaries in this mode.  



Resolution


To correct this issue, please follow these instructions:

 

  1. Open FSX or Prepar3D
  2. Go To Options/Settings/Display/Weather
  3. In the Cloud Details, enable Detailed Clouds
  4. Set to Cloud Density to Maximum

 

More Information


For more information please visit:

 

PMDG Weather Radar Troubleshooting Article:

http://support.precisionmanuals.com/kb/a109/weather-radar-troubleshooting.aspx

 

HiFi Forums:

http://www.hifitechinc.com/forums

 

HiFi Support Center:

http://support.hifitechinc.com/

Keywords: Shutdown, immediate close, opens then closes, connection issue, modified HOSTS file

We have found that certain unauthorized versions of Active Sky (including previous version for other platforms) can modify system files, potentially install malware on the user's system, and attempt to spoof servers that Active Sky connects to.

If you have installed an unauthorized version of Active Sky, and subsequently attempt to run a legitimate licensed version of Active Sky, you may be subject to this issue.  This issue can be confirmed by reviewing your HOSTS file located at:
C:\Windows\System32\drivers\etc

If any "hifisimtech.com" or "hifitechinc.com" entries exist here, this confirms the spoofing and redirection of our servers which will not be able to connect.  If your system is affected by this, it is due to installing unauthorized software and the unauthorized system modifications it makes to attempt to bypass licensing and break into our data services.  Malware and other unintended negative changes on your system are common issues when using unauthorized software.

If you have purchased a valid license of Active Sky and are affected by this issue, please reset/clear your HOSTS file.  You can refer to this Microsoft support article for instructions: https://support.microsoft.com/en-us/help/972034/how-to-reset-the-hosts-file-back-to-the-default

After clearing the HOSTS file, we also recommend repairing and/or reinstalling Windows to clear any other potential malware/system changes that this previous unauthorized version may have installed.

Related Product: ASP4
Keywords: Crash to desktop, CTD, Tower View, vPilot 


Description

Users experiencing crash to desktop (CTD) when accessing tower view in Prepar3D v4 with vPilot Client running may resolve the issue by following the instructions below:


Cause

vPilot is using specific network ports that conflict with default AS port(s)


Resolution

Change the AS ports for radar comms and http companion app to ports outside the range that vPilot is using. We Suggest 18000 and 18001 respectively.

To change the ports used in ASP4, navigate to Options\General options and change the values in their corresponding windows.  For additional reference, see the attachment images showing these options.